Saturn Spot
 

 


Go Back   Saturn Spot > Saturn Model & Technical Discussion > Saturn ION > Saturn ION - Technical


Reply
 
Thread Tools Display Modes
Old 04-09-2010, 03:02 AM   #1
Ole_bullitt
Banned
 
Join Date: Mar 2010
Posts: 2
Default Overheating - AC won't work


This probably won't end well. About a month ago, I had the water pump replaced because it was leaking. My mechanic had some problems in getting that done at the time due to peculiarities with the Ion's water pump.

On Saturday while I was driving to the airport, I was stuck in traffic and noticed that the car didn't downshift in traffic. I found out that my wife had noticed this a couple of weeks prior but didn't tell me.

I got a call from her this afternoon that the "Check Gauge" light appears and a pinging sound came on. She told me when she got home that the car was overheating.

I am hoping that there is something wrong with the water pump or the thermostat. But I wonder if the tranny is blown and I am really up a creek. Any thoughts?

Ole_bullitt is offline   Reply With Quote
Old 04-09-2010, 09:39 PM   #2
RjION
Senior Member
 
RjION's Avatar
 
Join Date: Jul 2006
Location: Arizona
Posts: 1,085
Default

Stop taking your car to a "mechanic" that has no idea what he is doing. Might be a good idea to try a Saturn dealer.
__________________
Rj Arizona
■ 07 I3 2.4L Sedan White ■14 Forte5 EX Pearl ■

Shut up and drive.
I have SL2, SW2, & ION pictures in the gallery under SaturnSdn & RjION
RjION is offline   Reply With Quote
Old 04-12-2010, 04:51 PM   #3
jonnyrocket92
Senior Member
 
jonnyrocket92's Avatar
 
Join Date: Mar 2004
Location: Mechanicsburg, Pa U.S.A.
Posts: 943
Default

Quote:
Originally Posted by RjION View Post
Stop taking your car to a "mechanic" that has no idea what he is doing. Might be a good idea to try a Saturn dealer.
are theyer any left? we changed to suzuki. I Find a gm dealer at least, the engines are the same in the cobalts..
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


spoc pa prez.

ex-saturn mechanic.
jonnyrocket92 is offline   Reply With Quote
Old 04-12-2010, 11:16 PM   #4
RjION
Senior Member
 
RjION's Avatar
 
Join Date: Jul 2006
Location: Arizona
Posts: 1,085
Default

Are any Saturn dealers left? Yes, in my area at least............
__________________
Rj Arizona
■ 07 I3 2.4L Sedan White ■14 Forte5 EX Pearl ■

Shut up and drive.
I have SL2, SW2, & ION pictures in the gallery under SaturnSdn & RjION
RjION is offline   Reply With Quote
Old 04-19-2010, 10:54 PM   #5
mooch1
Member
 
Join Date: Jul 2009
Location: canada
Posts: 81
Default

hi , i have a 1999 saturn SL 4 door,,,i can't find the problem ...i want to take it to a garage ,,but i will get robbed!!...in the morning after 1-3 days without use ..when i start it , it starts right away but it shakes and runs really rough and it's about to turn off if i don't keep the gas on ....i changed the coolant sensor..plugs -wires- pvc valve and hose-AIR FILTER etc ...what can it be?...if i take off the car gives thumps like on the transmission when downshifting(automatic trans) the idle is eratic etc and all over the place like 2000rpm ....then i get to work , park it....start it at the end of the day ,,runs great like it was when new!!!??!!...what can it be?...any type of sensor like the crank sensor do this?..anyone out there ever had this?....engine light is off ...but came on once and then off again.....HELP!!
mooch1 is offline   Reply With Quote
Old 04-19-2010, 11:56 PM   #6
RjION
Senior Member
 
RjION's Avatar
 
Join Date: Jul 2006
Location: Arizona
Posts: 1,085
Default

So mooooooch1 why are you posting this in the ION section under an open post for Overheating - AC won't work ?
__________________
Rj Arizona
■ 07 I3 2.4L Sedan White ■14 Forte5 EX Pearl ■

Shut up and drive.
I have SL2, SW2, & ION pictures in the gallery under SaturnSdn & RjION
RjION is offline   Reply With Quote
Old 04-20-2010, 12:44 PM   #7
mooch1
Member
 
Join Date: Jul 2009
Location: canada
Posts: 81
Default

Quote:
Originally Posted by RjION View Post
So mooooooch1 why are you posting this in the ION section under an open post for Overheating - AC won't work ?
ooopss!...sorry ....can you re-direct me?... BTW...i have a saturn ION 2007 too !!....thanks and sorry for the mix-up...
mooch1 is offline   Reply With Quote
Old 04-20-2010, 05:26 PM   #8
RjION
Senior Member
 
RjION's Avatar
 
Join Date: Jul 2006
Location: Arizona
Posts: 1,085
Default

You can't redirect yourself?
__________________
Rj Arizona
■ 07 I3 2.4L Sedan White ■14 Forte5 EX Pearl ■

Shut up and drive.
I have SL2, SW2, & ION pictures in the gallery under SaturnSdn & RjION
RjION is offline   Reply With Quote
Old 04-20-2010, 05:32 PM   #9
mooch1
Member
 
Join Date: Jul 2009
Location: canada
Posts: 81
Default

how?...how do i start a new thread?
mooch1 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:55 PM.

© 2006 - 2016 CrowdGather | Advertisers | Investors | Legal | A member of the Crowdgather Forum Community

 

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.