Saturn Spot


Go Back   Saturn Spot > Community > General Discussion

Thread Tools Display Modes
Old 10-27-2017, 07:49 PM   #1
Junior Member
Join Date: Oct 2017
Posts: 1
Default 2007 2.2 saturn vue fwd

replaced plugs, ign control module rubber coil boots ,crank sensor cars runs til good warmed and stalls out and won't start til cooled off. any help would be appreciated or fixes.

stic2me56 is offline   Reply With Quote
Old 11-19-2017, 08:34 AM   #2
Senior Member
derfderf's Avatar
Join Date: Nov 2006
Location: Out on the Tiles
Posts: 624

ckp (crank Position Sensor)

any SES codes?

Marginal CKP often goes open circuit when hot -- wound coil inside w break in it expands and the coil physically separates at the break. Open circuit. No spark, no fuel inj pulse = no run.

Check CKP connector pigtail for corrosion, integrity and tight fit.

Does it stall reproducibly (like after 12 +/- 3 minutes, when temp gauge gets to a certain identicalish spot, etc? Meaning is there a pattern more specific than just warmed up? (not being sarcastic).

Check the CKP wiring at the ECM cor corrosion under the contacts where it attaches. May be losing continuity of the circuit if the electrical connections are poor.

Is battery being run down?
Is charging light on?

If you start it in the driveway and just let it run, will it eventually stall and become unstartable until cooler?
97 SC2 ~253K

95 SC2 ~235K +/running-- "All in the Family"
derfderf is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 10:26 PM.

© 2006 - 2016 CrowdGather | Advertisers | Investors | Legal | A member of the Crowdgather Forum Community


Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.