Saturn Spot
 

 


Go Back   Saturn Spot > Saturn Model & Technical Discussion > Saturn Vue > Saturn Vue - Technical


Reply
 
Thread Tools Display Modes
Old 06-06-2006, 02:56 PM   #1
yellekkel
Banned
 
Join Date: Sep 2003
Location: Mechanicsburg, PA
Posts: 1,407
Default Service Engine Soon


We just bought a 2003 AWD V6 Vue on Saturday from a saturn dealership and sunday night the service engine soon light came on. Has anyone else had problems like this? We checked the oil and the gas cap and every other fluid and everything is fine. Any thoughts?

yellekkel is offline   Reply With Quote
Old 06-06-2006, 04:27 PM   #2
PurdueGuy
Senior Member
 
Join Date: Feb 2005
Location: West Lafayette, Indiana
Posts: 6,253
Default

Whenever that light comes on, there should be a code in the computer. Swing by a parts store and have them check it - should tell you the problem real quick.
PurdueGuy is offline   Reply With Quote
Old 06-06-2006, 05:15 PM   #3
yellekkel
Banned
 
Join Date: Sep 2003
Location: Mechanicsburg, PA
Posts: 1,407
Default

I did, they at first said that the gas cap was on wrong but the thing is since I have the Ion I know how to put a gas cap on. But now they are finding something else coming up so I don't know what it is.
yellekkel is offline   Reply With Quote
Old 07-14-2006, 06:56 AM   #4
Spacestation 1
Junior Member
 
Join Date: Feb 2006
Location: Alabama
Posts: 14
Default

Hi,
I aswell own a 2003.....just the 4 cyl. 2 wheel drive. My check engine light came on the next week after I bought it....but clears anytime I disconnect my battery. The "Service Engine Soon" light now has been on about a year.....I took mine to several different "Autozones & Advance Autoparts" and they all say that they can't read the computers code by "the scan"? So the regular scanning from a parts retailer store won't work......I've been EVERYWHERE but Saturn stealership.
Spacestation 1 is offline   Reply With Quote
Old 07-28-2008, 04:45 AM   #5
firefighter24
Junior Member
 
Join Date: Jul 2005
Location: Emigsville,PA
Posts: 17
Default

I recently bought a 2002 vue 6 cyl. AWD and the same thing happened to me I had it about a week and The SES light came on I checked the gas cap to and it was on right so I took it back to Saturn and they ended up replacing the Engine Control module and the SES light and codes went away for around 38 miles and it came back on so I took it back and now they are replacing the throttle body. So I will see somtime this week if they fixed it.
__________________
Derek
Volunteer Firefighter\EMT
SPOC-PA Member
2000 SL1
2002 Vue
firefighter24 is offline   Reply With Quote
Old 08-06-2008, 09:03 AM   #6
firefighter24
Junior Member
 
Join Date: Jul 2005
Location: Emigsville,PA
Posts: 17
Default

Update on the problem on my 2002 Vue v6. It was the wiring between the ECM and the throttle body was bad they rewired it and the SES light has not come on . They never did replace the throttle body.
__________________
Derek
Volunteer Firefighter\EMT
SPOC-PA Member
2000 SL1
2002 Vue
firefighter24 is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:24 AM.

© 2006 - 2016 CrowdGather | Advertisers | Investors | Legal | A member of the Crowdgather Forum Community

 

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.