Saturn Spot
 

 


Go Back   Saturn Spot > Saturn Model & Technical Discussion > How Do You Fix This? > Technical Issues


 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-09-2005, 04:38 PM   #1
MickSaturn
Junior Member
 
Join Date: Apr 2005
Location: Northern VA
Posts: 21
Default 94 SL2 Auto Transmission - Shifts Hard into Reverse


I've been having a problem with my auto transmission for quite some time. Often when I go to shift into reverse, it doesn't shift right away. Sometimes when it just isn't shifting, if I give it a little gas, it'll then shift really hard into reverse. Really a pain.

I recently changed my transmission fluid and now I hear a noise ( not high like a whistle but it seems to fluctuate with the RPMs of the engine). Also now it will sometimes shift a little sloppy into 2nd...kind of like a double pump kind of feeling if that makes any sense. I never noticed either of these problems before changing the fluid. I thought maybe I didn't add enough fluid but I added what the manual said.

Any ideas?

MickSaturn is offline   Reply With Quote
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:22 AM.

© 2006 - 2016 CrowdGather | Advertisers | Investors | Legal | A member of the Crowdgather Forum Community

 

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.