Saturn Spot
 

 


Go Back   Saturn Spot > Saturn Model & Technical Discussion > Saturn Outlook


Reply
 
Thread Tools Display Modes
Old 04-29-2015, 04:25 PM   #1
dricketts
Junior Member
 
Join Date: Apr 2015
Posts: 6
Default reduced power/speed


I have a 2009 outlook that has a error on dash saying reduced power. it started the other day when I had problems with the suv wouldn't start after filling up the tank. After a few pumps of the gas pedal and few try's it started. now it has this error. Has anyone had this problem?

dricketts is offline   Reply With Quote
Old 04-29-2015, 07:05 PM   #2
goaliemo
Community Moderator
 
goaliemo's Avatar
 
Join Date: Jun 2014
Location: Northshore, Louisiana
Posts: 1,243
Default

Welcome to the forum.

I am going to move this to the correct area of the forum.

Sounds like a fuel issue. I would start with changing the fuel filter, running gas treatment through it, and spraying throttle body cleaner through.
__________________
Billy, Louisiana
03 Ion-1 Sedan (Topanga)
06 Ion Redline- HPTuned, still slow.
92 SL1-Sold
04 Ion
goaliemo is offline   Reply With Quote
Old 04-29-2015, 07:13 PM   #3
dricketts
Junior Member
 
Join Date: Apr 2015
Posts: 6
Default

thanks for the reply. I was told there is no filter its all in the fuel tank on the pump. so I am ordering a fuel pump and pressure sensor. I hope this corrects the problem.
dricketts is offline   Reply With Quote
Old 04-29-2015, 07:19 PM   #4
GMCustomerService
Junior Member
 
GMCustomerService's Avatar
 
Join Date: Apr 2011
Posts: 28
Default

Quote:
Originally Posted by dricketts View Post
I have a 2009 outlook that has a error on dash saying reduced power. it started the other day when I had problems with the suv wouldn't start after filling up the tank. After a few pumps of the gas pedal and few try's it started. now it has this error. Has anyone had this problem?
Hi dricketts,

I’m sorry to hear that you are experiencing a “reduced power” error on your dash. I see that goaliemo has already given you some feedback, however, please feel free to send us a private message if you have any questions or would like our assistance!

Best,

Shane M.
GM Customer Care
__________________
Check out the NEW Owner Center at: My.GM.com
GMCustomerService is offline   Reply With Quote
Old 04-29-2015, 07:22 PM   #5
goaliemo
Community Moderator
 
goaliemo's Avatar
 
Join Date: Jun 2014
Location: Northshore, Louisiana
Posts: 1,243
Default

I didn't know they switched that in 05. I just googled it. That is odd. My 06 Redline has a filter on the outside.

Hopefully that works. Make sure to let us know!

Shane,
PM me, I have a question for you guys at GM Customer Service.
__________________
Billy, Louisiana
03 Ion-1 Sedan (Topanga)
06 Ion Redline- HPTuned, still slow.
92 SL1-Sold
04 Ion
goaliemo is offline   Reply With Quote
Old 05-03-2015, 06:14 AM   #6
derfderf
Senior Member
 
derfderf's Avatar
 
Join Date: Nov 2006
Location: Out on the Tiles
Posts: 624
Default

SES light on? Any codes?
__________________
derf/PA
97 SC2 ~253K

95 SC2 ~235K +/running-- "All in the Family"
derfderf is offline   Reply With Quote
Old 05-26-2015, 05:27 AM   #7
derfderf
Senior Member
 
derfderf's Avatar
 
Join Date: Nov 2006
Location: Out on the Tiles
Posts: 624
Default

I must ask again....Stop by autozone or similar to get codes read for free. I wouldn't move forward w the fuel pump until we check other fuel system related issues, which, from a short search on the net, are widespread across GM during this time period for all the vehicles built on the same body platform. But we need to know is the service engine soon (SES) light on, and if so, what codes are stored (post Pxxx not the description of the code).

Possible
----vent solenoid issue
----purge solenoid issue
----corroded vent solenoid wiring
----fuel tank harness to body harness connection issues

No more guessing on my part. Need the codes.
One of the parts mentioned above cannot be accessed without dropping the tank. So don't rush to drop the tank. You may not need to.


Quote:
Originally Posted by derfderf View Post
SES light on? Any codes?
__________________
derf/PA
97 SC2 ~253K

95 SC2 ~235K +/running-- "All in the Family"
derfderf is offline   Reply With Quote
Old 05-26-2015, 12:59 PM   #8
dricketts
Junior Member
 
Join Date: Apr 2015
Posts: 6
Default

thanks for the reply. i forgot the code but it said it was a sensor on the gas tank. so now when i stop to fill it up i have to pump the gas to get gas to injectors. first time it did it i thought o god the please let this car start b4 i blow it up. so i pumped the gas peddle and it started up. so figured it was that sensor for sure. so i thought if i have to pull tank i mine as well put in new pump. the suv has 200k miles on it so i thought its due for a new one. i have to get my code reader out and get the code again. it might be something different this time.
__________________
David Ricketts
dricketts is offline   Reply With Quote
Old 05-27-2015, 02:05 AM   #9
derfderf
Senior Member
 
derfderf's Avatar
 
Join Date: Nov 2006
Location: Out on the Tiles
Posts: 624
Default

Assume nothing unless spending extra money for no reason appeals to you.

Awaiting the code(s).

Derf
__________________
derf/PA
97 SC2 ~253K

95 SC2 ~235K +/running-- "All in the Family"
derfderf is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:44 PM.

© 2006 - 2016 CrowdGather | Advertisers | Investors | Legal | A member of the Crowdgather Forum Community

 

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.