Saturn Spot
 

 


Go Back   Saturn Spot > Saturn Model & Technical Discussion > How Do You Fix This?


Reply
 
Thread Tools Display Modes
Old 08-02-2013, 05:34 PM   #1
Mickeycat
Banned
 
Join Date: Aug 2013
Location: Northern California
Posts: 1
Default Engine Accelerates at Start and remains there


2001 SL2 5 Speed w/140k miles

When I go to start my car the engine races to 3500 and decreases to 3k and remains there. How can I stop my engine from racing and get it so it idles and drives normally. It usually idles at 800rpm. I took the car out on the freeway to see if it would fix itself. But, it did not help. The carburetor looked clean. Waterpump replaced in June 2013 by shop.

Mickeycat is offline   Reply With Quote
Old 08-02-2013, 11:30 PM   #2
Ssicarman
Senior Member
 
Ssicarman's Avatar
 
Join Date: Jul 2002
Location: Canada
Posts: 4,706
Default

Welcome to the Board.

Check for vacuum leaks. 3000RPM sounds about the right RPM for the brake booster vacuum hose to be off/leaking or the PCV vacuum hose to be off/leaking.
If those are ok possible jammed throttle cable.
__________________
A lousy day in Paradise is still a day in Paradise.
Ssicarman is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:34 AM.

© 2006 - 2016 CrowdGather | Advertisers | Investors | Legal | A member of the Crowdgather Forum Community

 

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.