Saturn Spot
 

 


Go Back   Saturn Spot > Saturn Model & Technical Discussion > How Do You Fix This?


Reply
 
Thread Tools Display Modes
Old 05-30-2014, 10:40 PM   #1
redfish067
Banned
 
Join Date: May 2014
Posts: 3
Default little car has issues


Just wanted to say hello, and I am interested to get some "good" advice on issues with my little car
its a 1997 Saturn SL
with 158,000 miles
it starts "spuddering" on acceleration, and on the in 4th/5th gears. its weird because it still gets 40MPG.
It has a code P0420 code, and from reading on here, it looks like its the catalytic converter. but first I need to figure out why its clogged. i know about 6 months ago, it was missing, and i ended up changing (1) of my coils
and about 1 month ago, i replaced the other one. so I (think) ithats not the problem. but I will shut up and listen for a direction to go, instead of "blindly" wandering around.
awaiting ANY advice

redfish067 is offline   Reply With Quote
Old 06-08-2014, 12:37 AM   #2
Southern Gardener
Junior Member
 
Join Date: Mar 2014
Location: Mississippi
Posts: 23
Default

I know it sounds simple, but I wonder if you just have water in the tank. My wife's van was having similar issues and after two bottles of ISO HEET and a full tank of fresh fuel, all was well. Just throwing that idea out there. I hope you have already found and corrected the problem.
Southern Gardner
Southern Gardener is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:39 PM.

© 2006 - 2016 CrowdGather | Advertisers | Investors | Legal | A member of the Crowdgather Forum Community

 

Powered by vBulletin® Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.